Back to overview
Downtime

Calls failed to connect

May 21, 2026 at 3:00pm UTC
Affected services
Participant Calls

Resolved
May 21, 2026 at 5:30pm UTC

The outage from our voice infra provider ended around 1:20 PM ET

Created
May 21, 2026 at 3:00pm UTC

An outage from our voice infra provider started around 10 AM ET